Entrar    Registrar

Ruído no processador Z80

Software e Hardware para uC Zilog

Moderadores: guest2003, 51

  • Autor
    Mensagem

Ruído no processador Z80

Mensagempor jroberto.vieira » 01 Fev 2009 13:39

Bom dia galera.

Preciso da ajuda de vocês.
Tenho um sistema antigo com processador Z80 que tava funcionando bem. Ele é um contador que libera um freio eletromagnetico quando começa a contagem e aciona quando termina a contagem.
Acontece que o contador se perde quando acontece do freio entrar ou sair. já coloquei snubers nos contatos e bobina do freio e o contador tem um filtro de linha interno tb. Alguma sugestão de vocês pra eliminar o ruído, mesmo que tenha que pendurar algum filtro na entrada do contador, tipo algum filtro adicional. To precisando da ajuda... é urgente a necessidade...

abraço a todos
jroberto.vieira
Bit
 
Mensagens: 36
Registrado em: 07 Dez 2006 07:55

Mensagempor Djalma Toledo Rodrigues » 28 Mar 2009 02:51

Verifique , ou melhor, troque os capacitores de desacoplamento do Z80

Se houver possibilidade use foto-acopladores para isolação galvânica dos circ. externos .
Avatar do usuário
Djalma Toledo Rodrigues
Dword
 
Mensagens: 2334
Registrado em: 03 Ago 2008 13:22

Mensagempor enigmabox » 28 Mar 2009 09:54

Acho que tu esta usando um Z80CTC ou 82C54 para contagem, no pino de entrada do contador vc colocou algum capacitor ao terra, por ex. 10nF?
Como vc aciona o freio? Atraves de rele mecanico ou estatico?
Se possivel use o +5V somente para o circuito da CPU e logicas. Não use esta tensão para outras funções.
Recomendo tb que cada circuito integrado seja desacoplado, a entrada de +5V, com um capacitor de 100nF para o terra e para cada 3 CI´s um capacitor de 100uF.
Se a falha for ocasionada por campo magnetico, deve ser feito uma blindagem do sistema.
enigmabox
 

Mensagempor Guri » 25 Set 2010 23:19

Varias vezes eu comentei a respeito desses problemas

O problema esta no retorno de ruidos vindos pela alimentação, esses ruidos estão na faixa de 1 até 100 mhz (EMI) e são liberados por circuitos pendurados na rede elétrica principalmente por circuitos indutivos.

Para eliminar esse problema é simples, pegue um pedaço de ferrite com 05mm de diametro por 1cm de comprimento ou um ferrite em espiral e enrrole sobre ele umas 3 até 6 voltas de fio rigido tipo cabinho de cobre 22.

Além disso coloque no pino de reset do processador um capacitor de 100nf ceramico em paralelo com o resistor de reset original.

Tanto na entrada quanto na saida desta bobina coloque capacitores em paralelo de 470pf + 1nf + 100uF...

Se você tiver um osciloscópio verificará na função triger o tal ruido...digital é claro...

Para você tirar a dúvida, basta alimentar seu circuito com uma bateria e verá que o problema desaparece, isso porque não tem conecção com a rede...
Guri
Byte
 
Mensagens: 139
Registrado em: 25 Abr 2010 09:05
Localização: Minas Gerais

Re: Ruído no processador Z80

Mensagempor Vonnilmam » 23 Jul 2016 19:12

Olá, a todos,

Eu já comentei sobre esses problemas.

Levando em conta que esteja tudo correto no seu FW eu faria o seguinte:

Uma simples bobina com ferrite de 0.5mm x 1cm, enrole 6 espiras de fio cabinho 20 ou 22 awg, sobre o ferrite, coloque esse filtro na alimentação 5volts do circuito, adicione dois capacitores de 100nf antes e depois do filtro, + um capacitor eletrôlitico de 10uF após o filtro.

Outra dica, lá no reset do processador, coloque um capacitor de 100nF do pino de reset para o VCC.

Provavelmente seu problema é ruido em alta frequencia que esta resetando seu mcu, essa dica irá resolver seu problema, depois por favor coloque o resultado aqui.

Obrigado
VonNilmam "Assembler" e agora "C"
Avatar do usuário
Vonnilmam
Byte
 
Mensagens: 446
Registrado em: 19 Out 2006 14:25
Localização: espacial

Voltar para Zilog

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante