Entrar    Registrar

Kernel panic - Ajuda

Fórum para discussão sobre Linux para processadores ARM

Moderadores: guest2003, 51, Renie, gpenga

  • Autor
    Mensagem

Kernel panic - Ajuda

Mensagempor denis » 05 Mai 2018 15:50

Pessoal,

Estou com um "kernel panic" ao executar o comando iwpriv

Bom, sei que o iwpriv é um package então deve rodar no user space.
Então o erro deve estar no driver? Dentro do kernel space?

Como descobrir qual é o driver? Olhando os arquivos .ko?

Estou usando uma Omega2 - Onion.

Qualquer ajuda é bem vinda.
Abs,
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Re: Kernel panic - Ajuda

Mensagempor Eduardo Augusto » 07 Mai 2018 09:14

Ola

Ainda não estou familiarizado com o comando por isso, fui consultar a documentação

iwpriv - configure optionals (private) parameters of a wireless network interface

Portanto, em User side vc roda um comando que espera um driver no Kernel side. Certifique-se que todos os drivers de wireless lan
estejam instalados/configurados. Veja se o fabricante disponibiliza uma versão de Kernel com o driver instalado on board.

Você pode consultar os drivers montados com o comando lsmod, caso não tenha nada veja na lista veja nos drivers compilados built in.
Ficam em /lib/modules/kernel-version/modules.builtin, oque possivelmente tbm não vai existir, uma vez que são os driver compilados dentro do kernel.


Att
Não é possível dormir com todas mulheres do mundo, mas deve-se fazer o esforço.
Avatar do usuário
Eduardo Augusto
Byte
 
Mensagens: 104
Registrado em: 03 Mar 2014 08:57
Localização: São Paulo, SP

Re: Kernel panic - Ajuda

Mensagempor tcpipchip » 07 Mai 2018 12:08

Opa, usando o OMEGA2 ?

Estas usando a imagem DOCKER deles ? Ou estas fazendo o teu proprio BUILD ?

Sugiro colocar o LEDE nele..

Vais usar NODEJS ?

PS: sexta feira agora desisti de usr o OMEGA2, apesar de custar U$5,00
------------------------------------------
http://www.youtube.com/tcpipchip
Avatar do usuário
tcpipchip
Dword
 
Mensagens: 5524
Registrado em: 11 Out 2006 22:32
Localização: TCPIPCHIPizinho!

Re: Kernel panic - Ajuda

Mensagempor denis » 07 Mai 2018 12:24

Eduardo Augusto escreveu:Ola

Ainda não estou familiarizado com o comando por isso, fui consultar a documentação

iwpriv - configure optionals (private) parameters of a wireless network interface

Portanto, em User side vc roda um comando que espera um driver no Kernel side. Certifique-se que todos os drivers de wireless lan
estejam instalados/configurados. Veja se o fabricante disponibiliza uma versão de Kernel com o driver instalado on board.

Você pode consultar os drivers montados com o comando lsmod, caso não tenha nada veja na lista veja nos drivers compilados built in.
Ficam em /lib/modules/kernel-version/modules.builtin, oque possivelmente tbm não vai existir, uma vez que são os driver compilados dentro do kernel.

Att


Eduardo,

Encontrei o driver na pasta /lib/modules/kernel-version/
Mas parece que o fabricante do driver não disponibiliza os fontes, apenas o .ko :cry:

Sabe me dizer se a mensagem "kernel panic" significa que o erro está no driver?
Ou tem a possibilidade ser no user space?
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Re: Kernel panic - Ajuda

Mensagempor denis » 07 Mai 2018 12:30

tcpipchip escreveu:Opa, usando o OMEGA2 ?

Estas usando a imagem DOCKER deles ? Ou estas fazendo o teu proprio BUILD ?

Sugiro colocar o LEDE nele..

Vais usar NODEJS ?

PS: sexta feira agora desisti de usr o OMEGA2, apesar de custar U$5,00


tcpipchip,
Ainda não precisei customizar a imagem, estou usando o build feito por eles.
Não vou usar o NODEJS.

Estou colocando o Omega2 no lugar de um módulo Wifi Microchip RN1723.

Qual a vantagem de colocar o LEDE nele?
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Re: Kernel panic - Ajuda

Mensagempor tcpipchip » 07 Mai 2018 13:57

Vai rodar ~20% mais rapido...

Além de suporte um numero maior de pacotes...

E um excelente make menuconfig...

Acabei desistindo do OMEGA2 (mt7688) pq me encomodei com compilação do UPM/MRAA e o pior, para omega2 tudo é em cima de DOCKER :(
------------------------------------------
http://www.youtube.com/tcpipchip
Avatar do usuário
tcpipchip
Dword
 
Mensagens: 5524
Registrado em: 11 Out 2006 22:32
Localização: TCPIPCHIPizinho!

Re: Kernel panic - Ajuda

Mensagempor Eduardo Augusto » 07 Mai 2018 14:17

Eduardo,

Encontrei o driver na pasta /lib/modules/kernel-version/
Mas parece que o fabricante do driver não disponibiliza os fontes, apenas o .ko :cry:

Sabe me dizer se a mensagem "kernel panic" significa que o erro está no driver?


O Kernel Panic é uma aviso de mal função do Kernel, como a tela azul do Win. O teste mais fácil para saber se é o driver é remova o driver, se ele for um modulo, e rode o comando que da pau:
rmmod nome-do-driver
comando-que-da-pau

Desculpa a pergunta

Oque você esta tentando fazer? Esta tentando colcoar algo da propria placa para funcionar ou algo que "plugou" na placa?

O Kernel tem de ser capaz de reconhecer o hardware antes de executar o modulo de software que da sentindo ao hardware. Rodando dmesg, você ve o driver sendo carregado corretamente?

Outra coisa que o costumamos esquecer é a device tree, esta declarada certinha? Confirme se tem que alterar a device tree do dispositivo para rodar esse dispositivo wifi.
Não é possível dormir com todas mulheres do mundo, mas deve-se fazer o esforço.
Avatar do usuário
Eduardo Augusto
Byte
 
Mensagens: 104
Registrado em: 03 Mar 2014 08:57
Localização: São Paulo, SP

Re: Kernel panic - Ajuda

Mensagempor denis » 07 Mai 2018 15:28

tcpipchip escreveu:Vai rodar ~20% mais rapido...

Além de suporte um numero maior de pacotes...

E um excelente make menuconfig...

Acabei desistindo do OMEGA2 (mt7688) pq me encomodei com compilação do UPM/MRAA e o pior, para omega2 tudo é em cima de DOCKER :(


Você conseguiu buildar a imagem do LEDE para o OMEGA2?
Eu vi um cara reclamando de problemas no WiFi depois que ele customizou uma imagem.
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Re: Kernel panic - Ajuda

Mensagempor denis » 07 Mai 2018 15:36

Eduardo Augusto escreveu:
Eduardo,

Encontrei o driver na pasta /lib/modules/kernel-version/
Mas parece que o fabricante do driver não disponibiliza os fontes, apenas o .ko :cry:

Sabe me dizer se a mensagem "kernel panic" significa que o erro está no driver?


O Kernel Panic é uma aviso de mal função do Kernel, como a tela azul do Win. O teste mais fácil para saber se é o driver é remova o driver, se ele for um modulo, e rode o comando que da pau:
rmmod nome-do-driver
comando-que-da-pau

Desculpa a pergunta

Oque você esta tentando fazer? Esta tentando colcoar algo da propria placa para funcionar ou algo que "plugou" na placa?

O Kernel tem de ser capaz de reconhecer o hardware antes de executar o modulo de software que da sentindo ao hardware. Rodando dmesg, você ve o driver sendo carregado corretamente?

Outra coisa que o costumamos esquecer é a device tree, esta declarada certinha? Confirme se tem que alterar a device tree do dispositivo para rodar esse dispositivo wifi.


Meu problema não é um hardware novo, na verdade estou tentando resolver um bug no driver o WiFi.
Se tiver um rede com o SSID: 하이네켄인증포어러 próximo o driver dá um crash na hora do scan e retorna kernel panic.

Por hora:
Eu consegui compilar o package do iwpriv, mas o problema está na chamada do IOCTL, no driver.
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Re: Kernel panic - Ajuda

Mensagempor tcpipchip » 07 Mai 2018 16:23

este é um problema que muita gente esta tendo...nao só vc, eu tambem...

Sorte que o meu cliente quer via 802.3
------------------------------------------
http://www.youtube.com/tcpipchip
Avatar do usuário
tcpipchip
Dword
 
Mensagens: 5524
Registrado em: 11 Out 2006 22:32
Localização: TCPIPCHIPizinho!

Re: Kernel panic - Ajuda

Mensagempor denis » 08 Mai 2018 12:51

tcpipchip escreveu:este é um problema que muita gente esta tendo...nao só vc, eu tambem...

Sorte que o meu cliente quer via 802.3


Consegui rodar o LEDE no Omega2, peguei um release disponível no site.
Aparentemente o WiFi está funcionando corretamente, tanto AP como Station (tive que gastar um tempinho nisso).

Isso revolve o bug encontrado no driver do WiFi.

Obrigado tcpipchip pela dica. :D
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Re: Kernel panic - Ajuda

Mensagempor tcpipchip » 08 Mai 2018 14:59

eu trabalho com MIPS24 faz 4 anos...comecei a me incomodar nos 2 ultimos meses por causa dos builds para NODE...e driver proprietário para WIFI, so tinha o .o :(

Falou,.,,
------------------------------------------
http://www.youtube.com/tcpipchip
Avatar do usuário
tcpipchip
Dword
 
Mensagens: 5524
Registrado em: 11 Out 2006 22:32
Localização: TCPIPCHIPizinho!

Re: Kernel panic - Ajuda

Mensagempor denis » 14 Mai 2018 16:41

tcpipchip escreveu:eu trabalho com MIPS24 faz 4 anos...comecei a me incomodar nos 2 ultimos meses por causa dos builds para NODE...e driver proprietário para WIFI, so tinha o .o :(

Falou,.,,


Estou rodando o LEDE 17.01.2, até agora tudo certo.
Porém o comando reboot não está mais fucionando, já viu isto antes?
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Re: Kernel panic - Ajuda

Mensagempor tcpipchip » 14 Mai 2018 20:07

hummmm ? que mensagem dá ?
------------------------------------------
http://www.youtube.com/tcpipchip
Avatar do usuário
tcpipchip
Dword
 
Mensagens: 5524
Registrado em: 11 Out 2006 22:32
Localização: TCPIPCHIPizinho!

Re: Kernel panic - Ajuda

Mensagempor denis » 15 Mai 2018 07:49

Pela serial do console, (já tentei reboot -n e -f)

Código: Selecionar todos
# reboot
[   66.947840] br-wlanap: port 2(wlan0-1) entered disabled state                                                                             
[   66.953827] br-wlanap: port 1(eth0.1) entered disabled state                 
[   67.000036] device eth0.1 left promiscuous mode                             
[   67.004716] device eth0 left promiscuous mode                               
[   67.009262] br-wlanap: port 1(eth0.1) entered disabled state                 
[   67.091928] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready             
[   67.122954] device wlan0-1 left promiscuous mode                             
[   67.127753] br-wlanap: port 2(wlan0-1) entered disabled state               
[   68.412830] wlan0: deauthenticating from 84:16:f9:98:43:08 by local choice (Reason: 3=DEAUTH_LEAVING)                                                       
[   71.426685] reboot: Restarting system


Após isso o Led amarelo apaga e nada mais acontece.
denis
Byte
 
Mensagens: 145
Registrado em: 06 Mar 2007 12:29
Localização: Americana - SP

Próximo

Voltar para Linux / uCLinux ( ARM ) / UNIX

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 0 visitantes