Raspberry pi Os Lite + Display 3.5" B rv2.0

Plataformas baseadas em ARM Cortex A8 ou superior

Moderadores: aluis-rcastro, guest2003, 51, Renie

Raspberry pi Os Lite + Display 3.5" B rv2.0

Mensagempor fabim » 22 Abr 2021 15:32

Ola, pessoal!

Estive um bom tempo buscando meios para resolver um problema que eu estava com python e X11, e agora tudo funciona lindamente na saida de video HDMI.
Tentei então, com dois displays que possuo, conforme o enunciado. um de REV A (a tela apresenta menssagens do kernel), e outro Rev B (não funciona já testei com 5 drives).
Como eu posso usar qualquer dos dois modelos, o fato de o original waveshare não funcionar, não está me encomodando.

O problema, é que, quando eu tento subir o X11, ele reclama que não existe um DISPLAY ou que não encontrou o fbcp, isso depende das tentativas, mais no gela ele relata que não pode subir (X11), logo como é um erro ele não sobe mais nada na sequencia de inicialização.

Estou usando o Raspberry pi Os Lite, ultima atualização do site, e instalei o X11 manualmente.

Alguém conseguiu utilizar o display com o X11 na versão Lite do Os?

Muito obrigado pela atenção !
Mano, ve só.
Sou responsável pelo que escrevo!!! E não pelo que você entende !!!
fabim
Dword
 
Mensagens: 4999
Registrado em: 16 Out 2006 10:18
Localização: aqui uái!!!?

Re: Raspberry pi Os Lite + Display 3.5" B rv2.0

Mensagempor xultz » 22 Abr 2021 16:32

Você já testou com o Os que não é Lite? Deu alguma diferença no comportamento?
98% das vezes estou certo, e não estou nem aí pros outros 3%.
Avatar do usuário
xultz
Dword
 
Mensagens: 2988
Registrado em: 13 Out 2006 18:41
Localização: Curitiba

Re: Raspberry pi Os Lite + Display 3.5" B rv2.0

Mensagempor sync » 22 Abr 2021 22:19

Caro Fabim

Aqui há algo sobre Ububtu e display Waveshare, talvez o amigo possa aproveitar algo

https://blog.victormendonca.com/2020/10 ... ntu-20.04/
sync
Byte
 
Mensagens: 155
Registrado em: 04 Mai 2020 16:11

Re: Raspberry pi Os Lite + Display 3.5" B rv2.0

Mensagempor tcpipchip » 23 Abr 2021 10:50

parece que ele já resolveu!
------------------------------------------
http://www.youtube.com/tcpipchip
Avatar do usuário
tcpipchip
Dword
 
Mensagens: 6491
Registrado em: 11 Out 2006 22:32
Localização: TCPIPCHIPizinho!

Re: Raspberry pi Os Lite + Display 3.5" B rv2.0

Mensagempor fabim » 26 Abr 2021 11:11

Pessoal, consegui fazer funcionar, mais ou menos, tem algo muito estranho no comportamento.

Estou debugando para descobrir o que está acontecendo, assim que conseguir descobrir colocarei o passo a passo aqui, como sempre faço!

Por enquanto, muito obrigado!
Mano, ve só.
Sou responsável pelo que escrevo!!! E não pelo que você entende !!!
fabim
Dword
 
Mensagens: 4999
Registrado em: 16 Out 2006 10:18
Localização: aqui uái!!!?


Voltar para RaspyBerry, BeagleBone, etc...

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante

x